diff options
author | Victor Stinner <vstinner@python.org> | 2020-10-26 15:43:47 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-10-26 15:43:47 (GMT) |
commit | 47e1afd2a1793b5818a16c41307a4ce976331649 (patch) | |
tree | e92f8f10238092c4a9b47d6ef9d3bd6c47bde70e /setup.py | |
parent | b510e101f8b5b31276bf97b921ca9247162881d2 (diff) | |
download | cpython-47e1afd2a1793b5818a16c41307a4ce976331649.zip cpython-47e1afd2a1793b5818a16c41307a4ce976331649.tar.gz cpython-47e1afd2a1793b5818a16c41307a4ce976331649.tar.bz2 |
bpo-1635741: _PyUnicode_Name_CAPI moves to internal C API (GH-22713)
The private _PyUnicode_Name_CAPI structure of the PyCapsule API
unicodedata.ucnhash_CAPI moves to the internal C API. Moreover, the
structure gets a new state member which must be passed to the
getcode() and getname() functions.
* Move Include/ucnhash.h to Include/internal/pycore_ucnhash.h
* unicodedata module is now built with Py_BUILD_CORE_MODULE.
* unicodedata: move hashAPI variable into unicodedata_module_state.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -878,7 +878,8 @@ class PyBuildExt(build_ext): self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c'])) # static Unicode character database self.add(Extension('unicodedata', ['unicodedata.c'], - depends=['unicodedata_db.h', 'unicodename_db.h'])) + depends=['unicodedata_db.h', 'unicodename_db.h'], + extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) # _opcode module self.add(Extension('_opcode', ['_opcode.c'])) # asyncio speedups |