summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-04-17 18:06:38 (GMT)
committerGitHub <noreply@github.com>2021-04-17 18:06:38 (GMT)
commit7f1305ef9ea7234e1a5aacbea17490232e9b7dc2 (patch)
treeb9aa4b5736f61444b4ea0897cfde12a50cf58a54 /setup.py
parent76beadb8ff86eb2bb248bf918bfb20c4069932f4 (diff)
downloadcpython-7f1305ef9ea7234e1a5aacbea17490232e9b7dc2.zip
cpython-7f1305ef9ea7234e1a5aacbea17490232e9b7dc2.tar.gz
cpython-7f1305ef9ea7234e1a5aacbea17490232e9b7dc2.tar.bz2
bpo-42333: Port _ssl extension to multiphase initialization (PEP 489) (GH-23253)
- Introduce sslmodule_slots - Introduce sslmodulestate - Use sslmodulestate - Get rid of PyState_FindModule - Move new structs and helpers to header file - Use macros to access state - Keep a strong ref to socket type
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 1 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 605f7d6..af38440 100644
--- a/setup.py
+++ b/setup.py
@@ -2428,14 +2428,6 @@ class PyBuildExt(build_ext):
self.missing.extend(['_ssl', '_hashlib'])
return None, None
- self.add(Extension(
- '_ssl', ['_ssl.c'],
- include_dirs=openssl_includes,
- library_dirs=openssl_libdirs,
- libraries=openssl_libs,
- depends=['socketmodule.h', '_ssl/debughelpers.c'])
- )
-
if openssl_rpath == 'auto':
runtime_library_dirs = openssl_libdirs[:]
elif not openssl_rpath:
@@ -2469,7 +2461,7 @@ class PyBuildExt(build_ext):
Extension(
'_ssl',
['_ssl.c'],
- depends=['socketmodule.h', '_ssl/debughelpers.c'],
+ depends=['socketmodule.h', '_ssl/debughelpers.c', '_ssl.h'],
**openssl_extension_kwargs
)
)