diff options
author | Georg Brandl <georg@python.org> | 2007-08-24 11:47:37 (GMT) |
---|---|---|
committer | Georg Brandl <georg@python.org> | 2007-08-24 11:47:37 (GMT) |
commit | 915c87d3e5d84c0635c2957f4ae9e96d0ab6705f (patch) | |
tree | 34235e16ccf2e4124eedb4ce5598e807298b61f2 /setup.py | |
parent | 8ec5754086a75aaf6febd38be2c3b0b8a0921cc4 (diff) | |
download | cpython-915c87d3e5d84c0635c2957f4ae9e96d0ab6705f.zip cpython-915c87d3e5d84c0635c2957f4ae9e96d0ab6705f.tar.gz cpython-915c87d3e5d84c0635c2957f4ae9e96d0ab6705f.tar.bz2 |
Bug #1765375: fix stripping of unwanted LDFLAGS.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -302,7 +302,8 @@ class PyBuildExt(build_ext): # strip out double-dashes first so that we don't end up with # substituting "--Long" to "-Long" and thus lead to "ong" being # used for a library directory. - env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1], '', env_val) + env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1], + ' ', env_val) parser = optparse.OptionParser() # Make sure that allowing args interspersed with options is # allowed |