diff options
author | Benjamin Peterson <benjamin@python.org> | 2014-08-10 03:04:19 (GMT) |
---|---|---|
committer | Benjamin Peterson <benjamin@python.org> | 2014-08-10 03:04:19 (GMT) |
commit | b30802b7a8a6e653e098cdb0108a729700e9eaaa (patch) | |
tree | 69149308a8227b2387c6e21c2e99cbfffe785fd9 /setup.py | |
parent | a61d058bf97291a51cc6481a3e76c2aa5500b37c (diff) | |
parent | acb8c5234302f8057b331abaafb2cc8697daf58f (diff) | |
download | cpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.zip cpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.tar.gz cpython-b30802b7a8a6e653e098cdb0108a729700e9eaaa.tar.bz2 |
merge 3.4 (#21121)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -19,6 +19,12 @@ from distutils.spawn import find_executable cross_compiling = "_PYTHON_HOST_PLATFORM" in os.environ +# Add special CFLAGS reserved for building the interpreter and the stdlib +# modules (Issue #21121). +cflags = sysconfig.get_config_var('CFLAGS') +py_cflags_nodist = sysconfig.get_config_var('PY_CFLAGS_NODIST') +sysconfig.get_config_vars()['CFLAGS'] = cflags + ' ' + py_cflags_nodist + def get_platform(): # cross build if "_PYTHON_HOST_PLATFORM" in os.environ: |