summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJoshua Root <jmr@macports.org>2020-04-22 07:44:10 (GMT)
committerGitHub <noreply@github.com>2020-04-22 07:44:10 (GMT)
commitb310700976524b4b99ee319c947ca40468716fc9 (patch)
treeee5ffee5d510dd540b0c5748424b3afecd53bda8 /setup.py
parent3a69f3caeeaea57048ed3bc3051e16854b9a4cd6 (diff)
downloadcpython-b310700976524b4b99ee319c947ca40468716fc9.zip
cpython-b310700976524b4b99ee319c947ca40468716fc9.tar.gz
cpython-b310700976524b4b99ee319c947ca40468716fc9.tar.bz2
bpo-38360: macOS: support alternate form of -isysroot flag (GH-16480)
It is possible to use either '-isysroot /some/path' (with a space) or '-isysroot/some/path' (no space in between). Support both forms in places where special handling of -isysroot is done, rather than just the first form. Co-authored-by: Ned Deily <nad@python.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d241dc0..8783721 100644
--- a/setup.py
+++ b/setup.py
@@ -170,7 +170,7 @@ def macosx_sdk_root():
return MACOS_SDK_ROOT
cflags = sysconfig.get_config_var('CFLAGS')
- m = re.search(r'-isysroot\s+(\S+)', cflags)
+ m = re.search(r'-isysroot\s*(\S+)', cflags)
if m is not None:
MACOS_SDK_ROOT = m.group(1)
else: