diff options
author | Davin Potts <applio@users.noreply.github.com> | 2019-02-02 04:52:23 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2019-02-02 04:52:23 (GMT) |
commit | e5ef45b8f519a9be9965590e1a0a587ff584c180 (patch) | |
tree | 261723cf76fbc9ef042b8ad4a3a6a581c7ae603c /setup.py | |
parent | d2b4c19d53f5f021fb1c7c32d48033a92ac4fe49 (diff) | |
download | cpython-e5ef45b8f519a9be9965590e1a0a587ff584c180.zip cpython-e5ef45b8f519a9be9965590e1a0a587ff584c180.tar.gz cpython-e5ef45b8f519a9be9965590e1a0a587ff584c180.tar.bz2 |
bpo-35813: Added shared_memory submodule of multiprocessing. (#11664)
Added shared_memory submodule to multiprocessing in time for first alpha with cross-platform tests soon to follow.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 11 insertions, 0 deletions
@@ -1592,6 +1592,17 @@ class PyBuildExt(build_ext): if (sysconfig.get_config_var('HAVE_SEM_OPEN') and not sysconfig.get_config_var('POSIX_SEMAPHORES_NOT_ENABLED')): multiprocessing_srcs.append('_multiprocessing/semaphore.c') + if (self.compiler.find_library_file(lib_dirs, 'rt') or + host_platform != 'cygwin'): + posixshmem_srcs = [ '_multiprocessing/posixshmem.c', + ] + libs = [] + if self.compiler.find_library_file(lib_dirs, 'rt'): + libs.append('rt') + exts.append( Extension('_posixshmem', posixshmem_srcs, + define_macros={}, + libraries=libs, + include_dirs=["Modules/_multiprocessing"])) exts.append ( Extension('_multiprocessing', multiprocessing_srcs, define_macros=list(macros.items()), |