summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-02-12 21:54:42 (GMT)
committerGitHub <noreply@github.com>2020-02-12 21:54:42 (GMT)
commite9e7d284c434768333fdfb53a3663eae74cb995a (patch)
treee9606ee5a7cf9801138448fe50aad004b05b188b /setup.py
parent45876a90e2663f12b90c2090ec3e48bd97841aae (diff)
downloadcpython-e9e7d284c434768333fdfb53a3663eae74cb995a.zip
cpython-e9e7d284c434768333fdfb53a3663eae74cb995a.tar.gz
cpython-e9e7d284c434768333fdfb53a3663eae74cb995a.tar.bz2
bpo-35081: Move dtoa.h header to the internal C API (GH-18489)
Move the dtoa.h header file to the internal C API as pycore_dtoa.h: it only contains private functions (prefixed by "_Py"). The math and cmath modules must now be compiled with the Py_BUILD_CORE macro defined.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 02f523c..51e67fe 100644
--- a/setup.py
+++ b/setup.py
@@ -734,12 +734,14 @@ class PyBuildExt(build_ext):
# math library functions, e.g. sin()
self.add(Extension('math', ['mathmodule.c'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE'],
extra_objects=[shared_math],
depends=['_math.h', shared_math],
libraries=['m']))
# complex math library functions
self.add(Extension('cmath', ['cmathmodule.c'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE'],
extra_objects=[shared_math],
depends=['_math.h', shared_math],
libraries=['m']))