diff options
author | Thomas Wouters <thomas@python.org> | 2008-04-07 00:25:59 (GMT) |
---|---|---|
committer | Thomas Wouters <thomas@python.org> | 2008-04-07 00:25:59 (GMT) |
commit | e9edcc401965c263820d45374eb00df7c4129b59 (patch) | |
tree | 85f62f7a6fbd25fd121796777837c76b1f6e5c91 /setup.py | |
parent | 5358434fd3899a369e4892807b0abaedaf2ea44b (diff) | |
download | cpython-e9edcc401965c263820d45374eb00df7c4129b59.zip cpython-e9edcc401965c263820d45374eb00df7c4129b59.tar.gz cpython-e9edcc401965c263820d45374eb00df7c4129b59.tar.bz2 |
Merged revisions 62179 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r62179 | thomas.wouters | 2008-04-06 01:39:15 +0200 (Sun, 06 Apr 2008) | 10 lines
Fix test_distutils to not fail when running 'make test' from a Python build
directory that is not the source directory (ie, one created using
'/path/to/source/configure'.) Leaves this test very slightly degraded in
that particular case, compared to the build-in-sourcedir case, but that case
isn't a particularly strong test either: neither test the actual path that
will be used after installing. There isn't a particularly good way to test
this, and a poor test beats a failing test.
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -119,6 +119,8 @@ class PyBuildExt(build_ext): raise ValueError("No source directory; cannot proceed.") # Figure out the location of the source code for extension modules + # (This logic is copied in distutils.test.test_sysconfig, + # so building in a separate directory does not break test_distutils.) moddir = os.path.join(os.getcwd(), srcdir, 'Modules') moddir = os.path.normpath(moddir) srcdir, tail = os.path.split(moddir) |