summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-02-09 16:02:24 (GMT)
committerChristian Heimes <christian@cheimes.de>2013-02-09 16:02:24 (GMT)
commit633a92ff20fac830409faa91f0e5bc7ff03759df (patch)
tree2a51497b99e7e78267260b5f336f836bcc4c3f31 /setup.py
parentfde43ec5cc32577a3f5c538bf9ac10ccadb9df55 (diff)
parent7d01a1eb2b636891fcac90f48290293bc2b9f3eb (diff)
downloadcpython-633a92ff20fac830409faa91f0e5bc7ff03759df.zip
cpython-633a92ff20fac830409faa91f0e5bc7ff03759df.tar.gz
cpython-633a92ff20fac830409faa91f0e5bc7ff03759df.tar.bz2
add proper dependencies on expat headers and sources
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 17 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5d38d29..4fd8efc 100644
--- a/setup.py
+++ b/setup.py
@@ -1405,6 +1405,7 @@ class PyBuildExt(build_ext):
define_macros = []
expat_lib = ['expat']
expat_sources = []
+ expat_depends = []
else:
expat_inc = [os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')]
define_macros = [
@@ -1414,12 +1415,25 @@ class PyBuildExt(build_ext):
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']
+ expat_depends = ['expat/ascii.h',
+ 'expat/asciitab.h',
+ 'expat/expat.h',
+ 'expat/expat_config.h',
+ 'expat/expat_external.h',
+ 'expat/internal.h',
+ 'expat/latin1tab.h',
+ 'expat/utf8tab.h',
+ 'expat/xmlrole.h',
+ 'expat/xmltok.h',
+ 'expat/xmltok_impl.h'
+ ]
exts.append(Extension('pyexpat',
define_macros = define_macros,
include_dirs = expat_inc,
libraries = expat_lib,
- sources = ['pyexpat.c'] + expat_sources
+ sources = ['pyexpat.c'] + expat_sources,
+ depends = expat_depends,
))
# Fredrik Lundh's cElementTree module. Note that this also
@@ -1432,6 +1446,8 @@ class PyBuildExt(build_ext):
include_dirs = expat_inc,
libraries = expat_lib,
sources = ['_elementtree.c'],
+ depends = ['pyexpat.c'] + expat_sources +
+ expat_depends,
))
else:
missing.append('_elementtree')