diff options
author | Erlend Egeberg Aasland <erlend.aasland@innova.no> | 2021-11-22 08:45:41 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-22 08:45:41 (GMT) |
commit | 718cee08cc082ece590f5a012253a405422da03d (patch) | |
tree | d46157e4d25fd4699fbc4f959bf30d319d4aea25 /setup.py | |
parent | 133c65a870e8bdcce7cd6a2bc6bd0cefbb2fa9f3 (diff) | |
download | cpython-718cee08cc082ece590f5a012253a405422da03d.zip cpython-718cee08cc082ece590f5a012253a405422da03d.tar.gz cpython-718cee08cc082ece590f5a012253a405422da03d.tar.bz2 |
bpo-45847: Port _bisect, _heapq, _json, _pickle, _random, and _zoneinfo to PY_STDLIB_MOD_SIMPLE (GH-29689)
Automerge-Triggered-By: GH:tiran
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 15 |
1 files changed, 6 insertions, 9 deletions
@@ -1004,18 +1004,15 @@ class PyBuildExt(build_ext): # libm is needed by delta_new() that uses round() and by accum() that # uses modf(). self.addext(Extension('_datetime', ['_datetimemodule.c'])) - # zoneinfo module - self.add(Extension('_zoneinfo', ['_zoneinfo.c'])) + self.addext(Extension('_zoneinfo', ['_zoneinfo.c'])) # random number generator implemented in C - self.add(Extension("_random", ["_randommodule.c"])) - # bisect - self.add(Extension("_bisect", ["_bisectmodule.c"])) - # heapq - self.add(Extension("_heapq", ["_heapqmodule.c"])) + self.addext(Extension("_random", ["_randommodule.c"])) + self.addext(Extension("_bisect", ["_bisectmodule.c"])) + self.addext(Extension("_heapq", ["_heapqmodule.c"])) # C-optimized pickle replacement - self.add(Extension("_pickle", ["_pickle.c"])) + self.addext(Extension("_pickle", ["_pickle.c"])) # _json speedups - self.add(Extension("_json", ["_json.c"])) + self.addext(Extension("_json", ["_json.c"])) # profiler (_lsprof is for cProfile.py) self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c'])) |