summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2010-08-23 16:47:09 (GMT)
committerMatthias Klose <doko@ubuntu.com>2010-08-23 16:47:09 (GMT)
commit7311729790172a6f85db0c31299f06feba217e87 (patch)
tree5b631fd0493b0afca1376241e933b44693c4f259 /setup.py
parent67e91ad9cfe17c8d0658d9310e69ee0f9ec48db7 (diff)
downloadcpython-7311729790172a6f85db0c31299f06feba217e87.zip
cpython-7311729790172a6f85db0c31299f06feba217e87.tar.gz
cpython-7311729790172a6f85db0c31299f06feba217e87.tar.bz2
Fix builds with builddir != srcdir, introduced in r83988.
os.path.dirname(__file__) points to the scrdir, not the builddir. Use os.getcwd() instead.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c81358c..8e51960 100644
--- a/setup.py
+++ b/setup.py
@@ -234,7 +234,7 @@ class PyBuildExt(build_ext):
# will fail.
with open(_BUILDDIR_COOKIE, "wb") as f:
f.write(self.build_lib.encode('utf-8', 'surrogateescape'))
- abs_build_lib = os.path.join(os.path.dirname(__file__), self.build_lib)
+ abs_build_lib = os.path.join(os.getcwd(), self.build_lib)
if abs_build_lib not in sys.path:
sys.path.append(abs_build_lib)