diff options
author | Matthias Klose <doko@ubuntu.com> | 2010-08-23 16:47:09 (GMT) |
---|---|---|
committer | Matthias Klose <doko@ubuntu.com> | 2010-08-23 16:47:09 (GMT) |
commit | 7311729790172a6f85db0c31299f06feba217e87 (patch) | |
tree | 5b631fd0493b0afca1376241e933b44693c4f259 /setup.py | |
parent | 67e91ad9cfe17c8d0658d9310e69ee0f9ec48db7 (diff) | |
download | cpython-7311729790172a6f85db0c31299f06feba217e87.zip cpython-7311729790172a6f85db0c31299f06feba217e87.tar.gz cpython-7311729790172a6f85db0c31299f06feba217e87.tar.bz2 |
Fix builds with builddir != srcdir, introduced in r83988.
os.path.dirname(__file__) points to the scrdir, not the builddir.
Use os.getcwd() instead.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -234,7 +234,7 @@ class PyBuildExt(build_ext): # will fail. with open(_BUILDDIR_COOKIE, "wb") as f: f.write(self.build_lib.encode('utf-8', 'surrogateescape')) - abs_build_lib = os.path.join(os.path.dirname(__file__), self.build_lib) + abs_build_lib = os.path.join(os.getcwd(), self.build_lib) if abs_build_lib not in sys.path: sys.path.append(abs_build_lib) |