diff options
author | Eric Smith <eric@trueblade.com> | 2008-02-23 03:09:44 (GMT) |
---|---|---|
committer | Eric Smith <eric@trueblade.com> | 2008-02-23 03:09:44 (GMT) |
commit | a73fbe791d0d41db543ebe39d2f6df0a4265be4b (patch) | |
tree | a07f32dc9b4de83ec186ee8a06430230edba48c3 /setup.py | |
parent | 73d796324242dc2164a0b5943bd08d6252a28651 (diff) | |
download | cpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.zip cpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.tar.gz cpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.tar.bz2 |
Added future_builtins, which contains PEP 3127 compatible versions of hex() and oct().
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -417,6 +417,9 @@ class PyBuildExt(build_ext): libraries=math_libs) ) exts.append( Extension('datetime', ['datetimemodule.c', 'timemodule.c'], libraries=math_libs) ) + # code that will be builtins in the future, but conflict with the + # current builtins + exts.append( Extension('future_builtins', ['future_builtins.c']) ) # random number generator implemented in C exts.append( Extension("_random", ["_randommodule.c"]) ) # fast iterator tools implemented in C |