summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-11-22 13:49:58 (GMT)
committerGitHub <noreply@github.com>2021-11-22 13:49:58 (GMT)
commitb451673f93465a27ee61e408190ee61cb9dbd5b6 (patch)
tree6e43cec1698370d69f9b303c88ecf0339852c393 /setup.py
parentd3062f672c92855b7e9e962ad4bf1a67abd4589b (diff)
downloadcpython-b451673f93465a27ee61e408190ee61cb9dbd5b6.zip
cpython-b451673f93465a27ee61e408190ee61cb9dbd5b6.tar.gz
cpython-b451673f93465a27ee61e408190ee61cb9dbd5b6.tar.bz2
bpo-45847: Port mmap, select, and _xxsubinterpreters to Py_STDLIB_MOD (GH-29703)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 28fd6da..d4eff36 100644
--- a/setup.py
+++ b/setup.py
@@ -1036,17 +1036,17 @@ class PyBuildExt(build_ext):
self.addext(Extension('spwd', ['spwdmodule.c']))
# select(2); not on ancient System V
- self.add(Extension('select', ['selectmodule.c']))
+ self.addext(Extension('select', ['selectmodule.c']))
# Memory-mapped files (also works on Win32).
- self.add(Extension('mmap', ['mmapmodule.c']))
+ self.addext(Extension('mmap', ['mmapmodule.c']))
# Lance Ellinghaus's syslog module
# syslog daemon interface
self.addext(Extension('syslog', ['syslogmodule.c']))
# Python interface to subinterpreter C-API.
- self.add(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c']))
+ self.addext(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c']))
#
# Here ends the simple stuff. From here on, modules need certain