diff options
author | Ned Deily <nad@acm.org> | 2012-08-05 21:56:21 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2012-08-05 21:56:21 (GMT) |
commit | 03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02 (patch) | |
tree | 7a21b7f81229476b8d2ead2e099abc129375cba3 /setup.py | |
parent | e768c39890a3071219d02b1b49e957d58b6410a3 (diff) | |
download | cpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.zip cpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.tar.gz cpython-03e2180b3f5c8fbbbf26e8ffc168ddf6269aba02.tar.bz2 |
Issue #15560: Fix building _sqlite3 extension on OS X with an SDK.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -981,12 +981,12 @@ class PyBuildExt(build_ext): if sys.platform == 'darwin': sysroot = macosx_sdk_root() - for d in inc_dirs + sqlite_inc_paths: - f = os.path.join(d, "sqlite3.h") - + for d_ in inc_dirs + sqlite_inc_paths: + d = d_ if sys.platform == 'darwin' and is_macosx_sdk_path(d): - f = os.path.join(sysroot, d[1:], "sqlite3.h") + d = os.path.join(sysroot, d[1:]) + f = os.path.join(d, "sqlite3.h") if os.path.exists(f): if sqlite_setup_debug: print("sqlite: found %s"%f) with open(f) as file: |