diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2006-08-06 22:07:04 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2006-08-06 22:07:04 (GMT) |
commit | 86070428898b811339b0e4454e10ebf6f6ad4641 (patch) | |
tree | 1d67d4a4ec97176259c0b4ec15d356351332ccda /setup.py | |
parent | 16ee33adfc45279544ec593f5123142ab12a302d (diff) | |
download | cpython-86070428898b811339b0e4454e10ebf6f6ad4641.zip cpython-86070428898b811339b0e4454e10ebf6f6ad4641.tar.gz cpython-86070428898b811339b0e4454e10ebf6f6ad4641.tar.bz2 |
[Patch #1464056] Ensure that we use the panelw library when linking with ncursesw.
Once I see how the buildbots react, I'll backport this to 2.4.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 6 insertions, 2 deletions
@@ -902,8 +902,12 @@ class PyBuildExt(build_ext): # Curses support, requiring the System V version of curses, often # provided by the ncurses library. + panel_library = 'panel' if (self.compiler.find_library_file(lib_dirs, 'ncursesw')): curses_libs = ['ncursesw'] + # Bug 1464056: If _curses.so links with ncursesw, + # _curses_panel.so must link with panelw. + panel_library = 'panelw' exts.append( Extension('_curses', ['_cursesmodule.c'], libraries = curses_libs) ) elif (self.compiler.find_library_file(lib_dirs, 'ncurses')): @@ -926,9 +930,9 @@ class PyBuildExt(build_ext): # If the curses module is enabled, check for the panel module if (module_enabled(exts, '_curses') and - self.compiler.find_library_file(lib_dirs, 'panel')): + self.compiler.find_library_file(lib_dirs, panel_library)): exts.append( Extension('_curses_panel', ['_curses_panel.c'], - libraries = ['panel'] + curses_libs) ) + libraries = [panel_library] + curses_libs) ) # Andrew Kuchling's zlib module. Note that some versions of zlib |