summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Baxter <anthonybaxter@gmail.com>2006-04-05 18:25:33 (GMT)
committerAnthony Baxter <anthonybaxter@gmail.com>2006-04-05 18:25:33 (GMT)
commit8e7b4908901e30f594e52d5fdcdc8b4e2d274ff1 (patch)
treed1cda8b0790ec0509bc28d4513538c7c5200897a /setup.py
parentc48c8db110fd5e3b1f8574e8e52f85d11d4c4fd4 (diff)
downloadcpython-8e7b4908901e30f594e52d5fdcdc8b4e2d274ff1.zip
cpython-8e7b4908901e30f594e52d5fdcdc8b4e2d274ff1.tar.gz
cpython-8e7b4908901e30f594e52d5fdcdc8b4e2d274ff1.tar.bz2
upgrade to final version of pysqlite 2.2.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index cb1d108..fb33bba 100644
--- a/setup.py
+++ b/setup.py
@@ -755,11 +755,10 @@ class PyBuildExt(build_ext):
PYSQLITE_VERSION = "2.2.0"
sqlite_defines = []
if sys.platform != "win32":
- sqlite_defines.append(('PYSQLITE_VERSION',
- '"%s"' % PYSQLITE_VERSION))
+ sqlite_defines.append(('MODULE_NAME', '"sqlite3"'))
else:
- sqlite_defines.append(('PYSQLITE_VERSION',
- '\\"'+PYSQLITE_VERSION+'\\"'))
+ sqlite_defines.append(('MODULE_NAME', '\\"sqlite3\\"'))
+
sqlite_defines.append(('PY_MAJOR_VERSION',
str(sys.version_info[0])))
sqlite_defines.append(('PY_MINOR_VERSION',