diff options
author | pxinwr <peixing.xin@windriver.com> | 2020-11-28 22:14:16 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-11-28 22:14:16 (GMT) |
commit | 00a6568ba37f0d815289776a51af46d0eac27384 (patch) | |
tree | 97f32d9f55bdae40f0fe7b69592a00aa7a0ba71c /setup.py | |
parent | 6a273fdc2a36f52fb70359149eff014f1b6b08d4 (diff) | |
download | cpython-00a6568ba37f0d815289776a51af46d0eac27384.zip cpython-00a6568ba37f0d815289776a51af46d0eac27384.tar.gz cpython-00a6568ba37f0d815289776a51af46d0eac27384.tar.bz2 |
bpo-31904: remove libnet dependency from detect_socket() for VxWorks (GH-23394)
Previously on VxWorks compiling socket extension module needs the libnet to link. Now VxWorks has moved the replied functions to libc. So removing libnet from setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 1 insertions, 5 deletions
@@ -1132,11 +1132,7 @@ class PyBuildExt(build_ext): def detect_socket(self): # socket(2) kwargs = {'depends': ['socketmodule.h']} - if VXWORKS: - if not self.compiler.find_library_file(self.lib_dirs, 'net'): - return - kwargs['libraries'] = ['net'] - elif MACOS: + if MACOS: # Issue #35569: Expose RFC 3542 socket options. kwargs['extra_compile_args'] = ['-D__APPLE_USE_RFC_3542'] |