summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2014-06-25 20:36:14 (GMT)
committerNed Deily <nad@acm.org>2014-06-25 20:36:14 (GMT)
commit04cdfa1147d5aadbee190b3aa2c4ccfd2d4a122d (patch)
tree3f7582d80bbbd7f46f39e78954e2b8e1c4b63359 /setup.py
parent975735f729df6b7767556d2d389b560dbc7500ac (diff)
downloadcpython-04cdfa1147d5aadbee190b3aa2c4ccfd2d4a122d.zip
cpython-04cdfa1147d5aadbee190b3aa2c4ccfd2d4a122d.tar.gz
cpython-04cdfa1147d5aadbee190b3aa2c4ccfd2d4a122d.tar.bz2
Issue #21811: Anticipated fixes to 3.x and 2.7 for OS X 10.10 Yosemite.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c0bb513..c909261 100644
--- a/setup.py
+++ b/setup.py
@@ -697,7 +697,9 @@ class PyBuildExt(build_ext):
if host_platform == 'darwin':
os_release = int(os.uname()[2].split('.')[0])
dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET')
- if dep_target and dep_target.split('.') < ['10', '5']:
+ if (dep_target and
+ (tuple(int(n) for n in dep_target.split('.')[0:2])
+ < (10, 5) ) ):
os_release = 8
if os_release < 9:
# MacOSX 10.4 has a broken readline. Don't try to build