summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael W. Hudson <mwh@python.net>2002-08-03 16:16:22 (GMT)
committerMichael W. Hudson <mwh@python.net>2002-08-03 16:16:22 (GMT)
commit210f5585d272d6f26e1ba64dbd84b726c69f899d (patch)
tree83c427d289ed492b79369418271bd8f1a5093f4a /setup.py
parentdc96ae6c7985628b5b3233071827ec10fbe42bfb (diff)
downloadcpython-210f5585d272d6f26e1ba64dbd84b726c69f899d.zip
cpython-210f5585d272d6f26e1ba64dbd84b726c69f899d.tar.gz
cpython-210f5585d272d6f26e1ba64dbd84b726c69f899d.tar.bz2
Another fix for:
[ 589427 ] standard include paths on command line _ssl still got /usr/include on the command line.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c67f724..6997029 100644
--- a/setup.py
+++ b/setup.py
@@ -397,7 +397,7 @@ class PyBuildExt(build_ext):
exts.append( Extension('_socket', ['socketmodule.c'],
depends = ['socketmodule.h']) )
# Detect SSL support for the socket module (via _ssl)
- ssl_incs = find_file('openssl/ssl.h', inc_dirs,
+ ssl_incs = find_file('openssl/ssl.h', self.compiler.include_dirs,
['/usr/local/ssl/include',
'/usr/contrib/ssl/include/'
]