summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-08-27 10:59:07 (GMT)
committerGitHub <noreply@github.com>2021-08-27 10:59:07 (GMT)
commit2ec9428e3516b6e7c6583687aa3b39fb96925577 (patch)
tree2cadc0b22c6fed6cb56ecf40561601b2dde0d3d9 /setup.py
parent94a3d2a6329ab7941e93ad2f5bcbb8af2b8b80d2 (diff)
downloadcpython-2ec9428e3516b6e7c6583687aa3b39fb96925577.zip
cpython-2ec9428e3516b6e7c6583687aa3b39fb96925577.tar.gz
cpython-2ec9428e3516b6e7c6583687aa3b39fb96925577.tar.bz2
bpo-44997: macOS does not support loadable SQLite extensions (GH-27979)
Authored-by: Ronald Oussoren <ronaldoussoren@mac.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 59b2548..9e411cb 100644
--- a/setup.py
+++ b/setup.py
@@ -1605,6 +1605,8 @@ class PyBuildExt(build_ext):
# if --enable-loadable-sqlite-extensions configure option is used.
if '--enable-loadable-sqlite-extensions' not in sysconfig.get_config_var("CONFIG_ARGS"):
sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1"))
+ elif MACOS and sqlite_incdir == os.path.join(MACOS_SDK_ROOT, "usr/include"):
+ raise DistutilsError("System version of SQLite does not support loadable extensions")
if MACOS:
# In every directory on the search path search for a dynamic