diff options
author | xdegaye <xdegaye@gmail.com> | 2019-04-09 15:20:08 (GMT) |
---|---|---|
committer | Miss Islington (bot) <31488909+miss-islington@users.noreply.github.com> | 2019-04-09 15:20:08 (GMT) |
commit | 2ee077f7955e0349074f16a7afee40b4914619f7 (patch) | |
tree | 91d18eaa00a318b6153be01f0411605b14c06e11 /setup.py | |
parent | 56065d4c8ac03042cb7e29ffda9b1ac544a37b4d (diff) | |
download | cpython-2ee077f7955e0349074f16a7afee40b4914619f7.zip cpython-2ee077f7955e0349074f16a7afee40b4914619f7.tar.gz cpython-2ee077f7955e0349074f16a7afee40b4914619f7.tar.bz2 |
bpo-36544 : Fix regression introduced in bpo-36146 (GH-12708)
https://bugs.python.org/issue36544
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -1642,6 +1642,7 @@ class PyBuildExt(build_ext): self.detect_crypt() self.detect_socket() self.detect_openssl_hashlib() + self.detect_hash_builtins() self.detect_dbm_gdbm() self.detect_sqlite() self.detect_platform_specific_exts() @@ -2184,6 +2185,7 @@ class PyBuildExt(build_ext): library_dirs=openssl_libdirs, libraries=openssl_libs)) + def detect_hash_builtins(self): # We always compile these even when OpenSSL is available (issue #14693). # It's harmless and the object code is tiny (40-50 KiB per module, # only loaded when actually used). |