summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-03-04 21:32:48 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-03-04 21:32:48 (GMT)
commit5f734f1b136529a3a17a3eff12cbad72c056f6e1 (patch)
treee45b5de2d021600267b4cc788f085d1e5d7f82b9 /setup.py
parent435aad878c50ecac3c43e3b528bab29b698e5ba9 (diff)
downloadcpython-5f734f1b136529a3a17a3eff12cbad72c056f6e1.zip
cpython-5f734f1b136529a3a17a3eff12cbad72c056f6e1.tar.gz
cpython-5f734f1b136529a3a17a3eff12cbad72c056f6e1.tar.bz2
Merged revisions 70172 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r70172 | ronald.oussoren | 2009-03-04 22:30:12 +0100 (Wed, 04 Mar 2009) | 7 lines Change framework search order when looking for Tcl/Tk on OSX. This is needed because the system linker looks in /Library/Framework before it looks in /System/Library frameworks. Without this patch _tkinter will be unusable when it is compiled on a system that has Tk 8.5 installed in /Library/Frameworks (and the Apple 8.4 install in /System/Library/Frameworks) ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 712f54c..522eb82 100644
--- a/setup.py
+++ b/setup.py
@@ -1083,8 +1083,8 @@ class PyBuildExt(build_ext):
# different the UNIX search logic is not sharable.
from os.path import join, exists
framework_dirs = [
- '/System/Library/Frameworks/',
'/Library/Frameworks',
+ '/System/Library/Frameworks/',
join(os.getenv('HOME'), '/Library/Frameworks')
]