summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPablo Galindo Salgado <Pablogsal@gmail.com>2021-09-29 13:18:33 (GMT)
committerGitHub <noreply@github.com>2021-09-29 13:18:33 (GMT)
commit6c1154b9de29e1c9cd3d05f5289543e5cff73895 (patch)
treef557d7822a9958f45d928461c0353492c8f2e19f /setup.py
parentf76889a88720b56c8174f26a20a8e676a460c7a6 (diff)
downloadcpython-6c1154b9de29e1c9cd3d05f5289543e5cff73895.zip
cpython-6c1154b9de29e1c9cd3d05f5289543e5cff73895.tar.gz
cpython-6c1154b9de29e1c9cd3d05f5289543e5cff73895.tar.bz2
bpo-44394: Ensure libexpat is linked against libm (GH-28617)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9e411cb..9e71a22 100644
--- a/setup.py
+++ b/setup.py
@@ -1767,7 +1767,9 @@ class PyBuildExt(build_ext):
('XML_POOR_ENTROPY', '1'),
]
extra_compile_args = []
- expat_lib = []
+ # bpo-44394: libexpact uses isnan() of math.h and needs linkage
+ # against the libm
+ expat_lib = ['m']
expat_sources = ['expat/xmlparse.c',
'expat/xmlrole.c',
'expat/xmltok.c']