diff options
author | Anthony Baxter <anthonybaxter@gmail.com> | 2006-04-09 15:07:40 (GMT) |
---|---|---|
committer | Anthony Baxter <anthonybaxter@gmail.com> | 2006-04-09 15:07:40 (GMT) |
commit | 8220174489e3f28b874b3b45516585c30e5999da (patch) | |
tree | a5b669f41c261aedf8ef1ace07418c825956c40b /setup.py | |
parent | a50794b62016e573b9f2a9e4a2a376c7360eae56 (diff) | |
download | cpython-8220174489e3f28b874b3b45516585c30e5999da.zip cpython-8220174489e3f28b874b3b45516585c30e5999da.tar.gz cpython-8220174489e3f28b874b3b45516585c30e5999da.tar.bz2 |
Python on OS X 10.3 and above now uses dlopen() (via dynload_shlib.c)
to load extension modules and now provides the dl module. As a result,
sys.setdlopenflags() now works correctly on these systems. (SF patch
#1454844)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -969,7 +969,7 @@ class PyBuildExt(build_ext): if sys.maxint == 0x7fffffff: # This requires sizeof(int) == sizeof(long) == sizeof(char*) dl_inc = find_file('dlfcn.h', [], inc_dirs) - if (dl_inc is not None) and (platform not in ['atheos', 'darwin']): + if (dl_inc is not None) and (platform not in ['atheos']): exts.append( Extension('dl', ['dlmodule.c']) ) # Thomas Heller's _ctypes module |