summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Baxter <anthonybaxter@gmail.com>2006-04-09 15:07:40 (GMT)
committerAnthony Baxter <anthonybaxter@gmail.com>2006-04-09 15:07:40 (GMT)
commit8220174489e3f28b874b3b45516585c30e5999da (patch)
treea5b669f41c261aedf8ef1ace07418c825956c40b /setup.py
parenta50794b62016e573b9f2a9e4a2a376c7360eae56 (diff)
downloadcpython-8220174489e3f28b874b3b45516585c30e5999da.zip
cpython-8220174489e3f28b874b3b45516585c30e5999da.tar.gz
cpython-8220174489e3f28b874b3b45516585c30e5999da.tar.bz2
Python on OS X 10.3 and above now uses dlopen() (via dynload_shlib.c)
to load extension modules and now provides the dl module. As a result, sys.setdlopenflags() now works correctly on these systems. (SF patch #1454844)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 065a115..eea9ee8 100644
--- a/setup.py
+++ b/setup.py
@@ -969,7 +969,7 @@ class PyBuildExt(build_ext):
if sys.maxint == 0x7fffffff:
# This requires sizeof(int) == sizeof(long) == sizeof(char*)
dl_inc = find_file('dlfcn.h', [], inc_dirs)
- if (dl_inc is not None) and (platform not in ['atheos', 'darwin']):
+ if (dl_inc is not None) and (platform not in ['atheos']):
exts.append( Extension('dl', ['dlmodule.c']) )
# Thomas Heller's _ctypes module