diff options
author | Brett Cannon <bcannon@gmail.com> | 2008-02-03 02:08:45 (GMT) |
---|---|---|
committer | Brett Cannon <bcannon@gmail.com> | 2008-02-03 02:08:45 (GMT) |
commit | 861e39678f574496c6e730753f12cbd7f59b6541 (patch) | |
tree | 32b73c81bbfa453ae673f89cd7251f211bfd5ab0 /setup.py | |
parent | 9a8bb0e316507434bf8d01f361e7e7b9d441875f (diff) | |
download | cpython-861e39678f574496c6e730753f12cbd7f59b6541.zip cpython-861e39678f574496c6e730753f12cbd7f59b6541.tar.gz cpython-861e39678f574496c6e730753f12cbd7f59b6541.tar.bz2 |
Directories from CPPFLAGS and LDFLAGS were being added in the reverse order for
searches as to how they were listed in the environment variable.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -327,7 +327,7 @@ class PyBuildExt(build_ext): parser.add_option(arg_name, dest="dirs", action="append") options = parser.parse_args(env_val.split())[0] if options.dirs: - for directory in options.dirs: + for directory in reversed(options.dirs): add_dir_to_list(dir_list, directory) if os.path.normpath(sys.prefix) != '/usr': |