diff options
author | Victor Stinner <vstinner@python.org> | 2020-06-22 15:39:32 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-06-22 15:39:32 (GMT) |
commit | c45dbe93b7094fe014442c198727ee38b25541c4 (patch) | |
tree | 9ee531ffa21bda6d8edfdcfdf046e75b98e597fa /setup.py | |
parent | 384621c42f9102e31ba2c47feba144af09c989e5 (diff) | |
download | cpython-c45dbe93b7094fe014442c198727ee38b25541c4.zip cpython-c45dbe93b7094fe014442c198727ee38b25541c4.tar.gz cpython-c45dbe93b7094fe014442c198727ee38b25541c4.tar.bz2 |
bpo-41078: Add pycore_list.h internal header file (GH-21057)
* Move _PyList_ITEMS() to pycore_list.h.
* The C extension "_heapq" is now built with Py_BUILD_CORE_MODULE
macro defined to access the internal C API.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -863,7 +863,8 @@ class PyBuildExt(build_ext): # bisect self.add(Extension("_bisect", ["_bisectmodule.c"])) # heapq - self.add(Extension("_heapq", ["_heapqmodule.c"])) + self.add(Extension("_heapq", ["_heapqmodule.c"], + extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) # C-optimized pickle replacement self.add(Extension("_pickle", ["_pickle.c"], extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) |