diff options
author | Nick Coghlan <ncoghlan@gmail.com> | 2006-05-29 12:43:05 (GMT) |
---|---|---|
committer | Nick Coghlan <ncoghlan@gmail.com> | 2006-05-29 12:43:05 (GMT) |
commit | c649ec5b69bd864914e02a2a9ec73c23bd307448 (patch) | |
tree | 795bb943ec4b6a13501e55aaa6a8efe9b86d0305 /setup.py | |
parent | c7c51147c73984137410ec03026b77e4a76ab61e (diff) | |
download | cpython-c649ec5b69bd864914e02a2a9ec73c23bd307448.zip cpython-c649ec5b69bd864914e02a2a9ec73c23bd307448.tar.gz cpython-c649ec5b69bd864914e02a2a9ec73c23bd307448.tar.bz2 |
Apply modified version of Collin Winter's patch #1478788
Renames functional extension module to _functools and adds a Python
functools module so that utility functions like update_wrapper can be
added easily.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -377,8 +377,8 @@ class PyBuildExt(build_ext): exts.append( Extension("_heapq", ["_heapqmodule.c"]) ) # operator.add() and similar goodies exts.append( Extension('operator', ['operator.c']) ) - # functional - exts.append( Extension("functional", ["functionalmodule.c"]) ) + # _functools + exts.append( Extension("_functools", ["_functoolsmodule.c"]) ) # Python C API test module exts.append( Extension('_testcapi', ['_testcapimodule.c']) ) # profilers (_lsprof is for cProfile.py) |