diff options
author | Christian Heimes <christian@python.org> | 2016-09-07 09:39:21 (GMT) |
---|---|---|
committer | Christian Heimes <christian@python.org> | 2016-09-07 09:39:21 (GMT) |
commit | dfb9ef13575bcc457544b408fc4e5eca3c5ed9b1 (patch) | |
tree | e7ef77c0e70a7120bd3a38ab451fe5b6c40c4f06 /setup.py | |
parent | 680cb152c5d220a74321fa905d4fc91bdec40fbb (diff) | |
download | cpython-dfb9ef13575bcc457544b408fc4e5eca3c5ed9b1.zip cpython-dfb9ef13575bcc457544b408fc4e5eca3c5ed9b1.tar.gz cpython-dfb9ef13575bcc457544b408fc4e5eca3c5ed9b1.tar.bz2 |
blake2: silence two more warnings on platforms with size_t < uint64_t. Don't use SSE2 when cross-compiling
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -894,7 +894,7 @@ class PyBuildExt(build_ext): blake2_deps.append('hashlib.h') blake2_macros = [] - if os.uname().machine == "x86_64": + if not cross_compiling and os.uname().machine == "x86_64": # Every x86_64 machine has at least SSE2. blake2_macros.append(('BLAKE2_USE_SSE', '1')) |