diff options
author | Georg Brandl <georg@python.org> | 2005-12-27 18:24:27 (GMT) |
---|---|---|
committer | Georg Brandl <georg@python.org> | 2005-12-27 18:24:27 (GMT) |
commit | e08fa29d0e5bf02006ae30d79c31a6fd02d62068 (patch) | |
tree | f0cd664c1d96fcb4e0f63bc8e37b8f8da984b20e /setup.py | |
parent | cd4d1e8b46ab59a9a00976998ffdc36b223e6e67 (diff) | |
download | cpython-e08fa29d0e5bf02006ae30d79c31a6fd02d62068.zip cpython-e08fa29d0e5bf02006ae30d79c31a6fd02d62068.tar.gz cpython-e08fa29d0e5bf02006ae30d79c31a6fd02d62068.tar.bz2 |
Bug #999767: make setup.py obey Setup.local wrt shared modules
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 21 |
1 files changed, 11 insertions, 10 deletions
@@ -148,17 +148,18 @@ class PyBuildExt(build_ext): self.extensions.remove(ext) if platform != 'mac': - # Parse Modules/Setup to figure out which modules are turned - # on in the file. - input = text_file.TextFile('Modules/Setup', join_lines=1) + # Parse Modules/Setup and Modules/Setup.local to figure out which + # modules are turned on in the file. remove_modules = [] - while 1: - line = input.readline() - if not line: break - line = line.split() - remove_modules.append( line[0] ) - input.close() - + for filename in ('Modules/Setup', 'Modules/Setup.local'): + input = text_file.TextFile(filename, join_lines=1) + while 1: + line = input.readline() + if not line: break + line = line.split() + remove_modules.append(line[0]) + input.close() + for ext in self.extensions[:]: if ext.name in remove_modules: self.extensions.remove(ext) |