summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-11-22 14:58:35 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-11-22 14:58:35 (GMT)
commite2ba87396cde5b57259405722910c560f7d237c6 (patch)
tree0cdaf8f73a8e5a915199eca6ae03b8c5355ca53f /setup.py
parenta191befb2d9b7757283ecc520113613eb46de019 (diff)
downloadcpython-e2ba87396cde5b57259405722910c560f7d237c6.zip
cpython-e2ba87396cde5b57259405722910c560f7d237c6.tar.gz
cpython-e2ba87396cde5b57259405722910c560f7d237c6.tar.bz2
Got angry and added support for pretty much the whole file and folder
manager. This should allow us the get rid of most of the FSSpecs, only navigation services remains to be done.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f471c03..6ce993d 100644
--- a/setup.py
+++ b/setup.py
@@ -745,6 +745,10 @@ class PyBuildExt(build_ext):
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Evt', ['evt/_Evtmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_File', ['file/_Filemodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_Folder', ['folder/_Foldermodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Fm', ['fm/_Fmmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Help', ['help/_Helpmodule.c'],