diff options
author | Gustavo Niemeyer <gustavo@niemeyer.net> | 2002-11-05 16:50:05 (GMT) |
---|---|---|
committer | Gustavo Niemeyer <gustavo@niemeyer.net> | 2002-11-05 16:50:05 (GMT) |
commit | f8ca8364c9682df468a982a5f29831b76521bb6d (patch) | |
tree | 21c553e9abd138d4989b138f4e778ae5a07a41bc /setup.py | |
parent | 6b016852f83621178ae053509c044d6fd27f46e3 (diff) | |
download | cpython-f8ca8364c9682df468a982a5f29831b76521bb6d.zip cpython-f8ca8364c9682df468a982a5f29831b76521bb6d.tar.gz cpython-f8ca8364c9682df468a982a5f29831b76521bb6d.tar.bz2 |
Patch implementing bz2 module.
* setup.py
(PyBuildExt.detect_modules): Included bz2 module detection.
* Modules/bz2module.c
* Lib/test/test_bz2.py
* Doc/lib/libbz2.tex
Included files implementing, testing, and documenting bz2 module.
* Doc/Makefile.deps
* Doc/lib/lib.tex
Include references to libbz2.tex.
* Misc/NEWS
(Library): Mention distutils' c++ linkage patch, and new bz2 module.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -702,6 +702,11 @@ class PyBuildExt(build_ext): exts.append( Extension('zlib', ['zlibmodule.c'], libraries = ['z']) ) + # Gustavo Niemeyer's bz2 module. + if (self.compiler.find_library_file(lib_dirs, 'bz2')): + exts.append( Extension('bz2', ['bz2module.c'], + libraries = ['bz2']) ) + # Interface to the Expat XML parser # # Expat was written by James Clark and is now maintained by a |