summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorpxinwr <peixing.xin@windriver.com>2019-04-15 09:02:20 (GMT)
committerVictor Stinner <vstinner@redhat.com>2019-04-15 09:02:20 (GMT)
commit236d0b75c41449a266201c683b4b0d6acdee02df (patch)
treee64301d83572746a0e310d4debbf27bb40cad6f3 /setup.py
parent2430d532e240dea55f0082d1e9bf2e0f3d7505be (diff)
downloadcpython-236d0b75c41449a266201c683b4b0d6acdee02df.zip
cpython-236d0b75c41449a266201c683b4b0d6acdee02df.tar.gz
cpython-236d0b75c41449a266201c683b4b0d6acdee02df.tar.bz2
bpo-31904: Don't build the _crypt extension on VxWorks (GH-12833)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 30caed5..9c83914 100644
--- a/setup.py
+++ b/setup.py
@@ -973,17 +973,18 @@ class PyBuildExt(build_ext):
def detect_crypt(self):
# crypt module.
+ if VXWORKS:
+ # bpo-31904: crypt() function is not provided by VxWorks.
+ # DES_crypt() OpenSSL provides is too weak to implement
+ # the encryption.
+ return
+
if self.compiler.find_library_file(self.lib_dirs, 'crypt'):
libs = ['crypt']
else:
libs = []
- if not VXWORKS:
- self.add(Extension('_crypt', ['_cryptmodule.c'],
- libraries=libs))
- elif self.compiler.find_library_file(self.lib_dirs, 'OPENSSL'):
- libs = ['OPENSSL']
- self.add(Extension('_crypt', ['_cryptmodule.c'],
+ self.add(Extension('_crypt', ['_cryptmodule.c'],
libraries=libs))
def detect_socket(self):