summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-21 13:08:47 (GMT)
committerGitHub <noreply@github.com>2021-11-21 13:08:47 (GMT)
commit2afa1a12669e1812a9fe8130c8f60052c4ad8bf8 (patch)
tree52a20a35fd96b37e8a369cbad8b4bee16225a408 /setup.py
parentf201d261cf53365b5769a434ca2bb21a892bd23f (diff)
downloadcpython-2afa1a12669e1812a9fe8130c8f60052c4ad8bf8.zip
cpython-2afa1a12669e1812a9fe8130c8f60052c4ad8bf8.tar.gz
cpython-2afa1a12669e1812a9fe8130c8f60052c4ad8bf8.tar.bz2
bpo-45847: Port codecs and unicodedata to PY_STDLIB_MOD (GH-29685)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 9ff5969..13ed636 100644
--- a/setup.py
+++ b/setup.py
@@ -1022,7 +1022,7 @@ class PyBuildExt(build_ext):
# profiler (_lsprof is for cProfile.py)
self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']))
# static Unicode character database
- self.add(Extension('unicodedata', ['unicodedata.c']))
+ self.addext(Extension('unicodedata', ['unicodedata.c']))
# _opcode module
self.add(Extension('_opcode', ['_opcode.c']))
# asyncio speedups
@@ -1432,11 +1432,12 @@ class PyBuildExt(build_ext):
def detect_multibytecodecs(self):
# Hye-Shik Chang's CJKCodecs modules.
- self.add(Extension('_multibytecodec',
- ['cjkcodecs/multibytecodec.c']))
+ self.addext(Extension('_multibytecodec',
+ ['cjkcodecs/multibytecodec.c']))
for loc in ('kr', 'jp', 'cn', 'tw', 'hk', 'iso2022'):
- self.add(Extension('_codecs_%s' % loc,
- ['cjkcodecs/_codecs_%s.c' % loc]))
+ self.addext(Extension(
+ f'_codecs_{loc}', [f'cjkcodecs/_codecs_{loc}.c']
+ ))
def detect_multiprocessing(self):
# Richard Oudkerk's multiprocessing module