diff options
author | Erlend Egeberg Aasland <erlend.aasland@innova.no> | 2021-11-22 09:57:50 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-11-22 09:57:50 (GMT) |
commit | 39f7d2ff01eb03f1dd87a019472a32cde6250e84 (patch) | |
tree | 50dbe01ca52666af9752fa4a74e6ba250c1e66f7 /setup.py | |
parent | 512dbf6f56364d359e16988b3fd7e766edfaebf9 (diff) | |
download | cpython-39f7d2ff01eb03f1dd87a019472a32cde6250e84.zip cpython-39f7d2ff01eb03f1dd87a019472a32cde6250e84.tar.gz cpython-39f7d2ff01eb03f1dd87a019472a32cde6250e84.tar.bz2 |
bpo-45847: Port _lfprof, _opcode, _asyncio, _queue, _statistics, and _typing to PY_STDLIB_MOD_SIMPLE (GH-29690)
Automerge-Triggered-By: GH:tiran
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 8 insertions, 10 deletions
@@ -1015,19 +1015,17 @@ class PyBuildExt(build_ext): self.addext(Extension("_json", ["_json.c"])) # profiler (_lsprof is for cProfile.py) - self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c'])) + self.addext(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c'])) # static Unicode character database self.addext(Extension('unicodedata', ['unicodedata.c'])) - # _opcode module - self.add(Extension('_opcode', ['_opcode.c'])) + self.addext(Extension('_opcode', ['_opcode.c'])) + # asyncio speedups - self.add(Extension("_asyncio", ["_asynciomodule.c"])) - # _queue module - self.add(Extension("_queue", ["_queuemodule.c"])) - # _statistics module - self.add(Extension("_statistics", ["_statisticsmodule.c"])) - # _typing module - self.add(Extension("_typing", ["_typingmodule.c"])) + self.addext(Extension("_asyncio", ["_asynciomodule.c"])) + + self.addext(Extension("_queue", ["_queuemodule.c"])) + self.addext(Extension("_statistics", ["_statisticsmodule.c"])) + self.addext(Extension("_typing", ["_typingmodule.c"])) # Modules with some UNIX dependencies -- on by default: # (If you have a really backward UNIX, select and socket may not be |