diff options
author | Brett Cannon <bcannon@gmail.com> | 2005-01-02 21:54:07 (GMT) |
---|---|---|
committer | Brett Cannon <bcannon@gmail.com> | 2005-01-02 21:54:07 (GMT) |
commit | 44837719ef2886da0671aed55e99cdae14d24b9d (patch) | |
tree | 20a2ef83307f6a0f8066f4ed3bffca3644a778c5 /setup.py | |
parent | c34f8673a194180ab3b258e821f72f25514aa948 (diff) | |
download | cpython-44837719ef2886da0671aed55e99cdae14d24b9d.zip cpython-44837719ef2886da0671aed55e99cdae14d24b9d.tar.gz cpython-44837719ef2886da0671aed55e99cdae14d24b9d.tar.bz2 |
Since it is a possibility that LDFLAGS or CPPFLAGS were set with options that
in no way affect library or include directories the code must take that into
account and not assume some options were found.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -270,8 +270,9 @@ class PyBuildExt(build_ext): parser.error = lambda msg: None parser.add_option(arg_name, dest="dirs", action="append") options = parser.parse_args(env_val.split())[0] - for directory in options.dirs: - add_dir_to_list(dir_list, directory) + if options.dirs: + for directory in options.dirs: + add_dir_to_list(dir_list, directory) if os.path.normpath(sys.prefix) != '/usr': add_dir_to_list(self.compiler.library_dirs, |