summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-18 09:56:26 (GMT)
committerGitHub <noreply@github.com>2021-11-18 09:56:26 (GMT)
commit5275e59c0c1b26226608e6c7c2548c26192d6575 (patch)
treeb8c81e855209532f569b8170c37baa48e8481667 /setup.py
parent345ba3f080c140dee3102f472bc166c2db191bcc (diff)
downloadcpython-5275e59c0c1b26226608e6c7c2548c26192d6575.zip
cpython-5275e59c0c1b26226608e6c7c2548c26192d6575.tar.gz
cpython-5275e59c0c1b26226608e6c7c2548c26192d6575.tar.bz2
bpo-45573: check for ossaudiodev in configure (GH-29614)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 8b9566e..a09cf18 100644
--- a/setup.py
+++ b/setup.py
@@ -1485,11 +1485,8 @@ class PyBuildExt(build_ext):
else:
self.missing.extend(['resource', 'termios'])
- # Platform-specific libraries
- if HOST_PLATFORM.startswith(('linux', 'freebsd', 'gnukfreebsd')):
- self.add(Extension('ossaudiodev', ['ossaudiodev.c']))
- elif not AIX:
- self.missing.append('ossaudiodev')
+ # linux/soundcard.h or sys/soundcard.h
+ self.addext(Extension('ossaudiodev', ['ossaudiodev.c']))
if MACOS:
self.add(Extension('_scproxy', ['_scproxy.c'],