summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-20 09:18:48 (GMT)
committerGitHub <noreply@github.com>2021-11-20 09:18:48 (GMT)
commit5596909eac4abdc9927c2e7751bea34fbcfdc624 (patch)
tree1dd04df859b59d224c59d5123fc6ca41697927b2 /setup.py
parentbe36e0634060c7d5dee8e8876fb888bbb53d992a (diff)
downloadcpython-5596909eac4abdc9927c2e7751bea34fbcfdc624.zip
cpython-5596909eac4abdc9927c2e7751bea34fbcfdc624.tar.gz
cpython-5596909eac4abdc9927c2e7751bea34fbcfdc624.tar.bz2
bpo-45847: Port _scproxy to PY_STDLIB_MOD (GH-29644)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 3e3075d..83a676b 100644
--- a/setup.py
+++ b/setup.py
@@ -1389,11 +1389,8 @@ class PyBuildExt(build_ext):
# linux/soundcard.h or sys/soundcard.h
self.addext(Extension('ossaudiodev', ['ossaudiodev.c']))
- if MACOS:
- self.add(Extension('_scproxy', ['_scproxy.c'],
- extra_link_args=[
- '-framework', 'SystemConfiguration',
- '-framework', 'CoreFoundation']))
+ # macOS-only, needs SystemConfiguration and CoreFoundation framework
+ self.addext(Extension('_scproxy', ['_scproxy.c']))
def detect_compress_exts(self):
# Andrew Kuchling's zlib module.