diff options
author | Ćukasz Langa <lukasz@langa.pl> | 2022-05-03 16:27:38 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-05-03 16:27:38 (GMT) |
commit | 6c25bf07e86b6d8d5e50488835f70539f382d7e0 (patch) | |
tree | 1ba0b23ccfc45a397eb510de520995d080fbef1e /setup.py | |
parent | feca9bbd1f6489f2b6d2783bfc22fdb96e45b69f (diff) | |
download | cpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.zip cpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.tar.gz cpython-6c25bf07e86b6d8d5e50488835f70539f382d7e0.tar.bz2 |
gh-89452: Prefer gdbm-compat over ndbm (#92208)
This makes macOS gdbm provided by Homebrew not segfault through correct
selection of the linked library (-lgdbm_compat) *AND* the correct ndbm-style
header (gdbm-ndbm.h instead of the invalid ndbm.h).
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1207,7 +1207,7 @@ class PyBuildExt(build_ext): if dbm_args: dbm_order = [arg.split('=')[-1] for arg in dbm_args][-1].split(":") else: - dbm_order = "ndbm:gdbm:bdb".split(":") + dbm_order = "gdbm:ndbm:bdb".split(":") dbmext = None for cand in dbm_order: if cand == "ndbm": |