summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-06-27 05:52:06 (GMT)
committerGitHub <noreply@github.com>2022-06-27 05:52:06 (GMT)
commit71868a0066a90519ccc6aeb75673ae882aaa03f0 (patch)
tree38feb32fba4753596c8adab08bc20aedbc1f1d7c /setup.py
parentd71f5adc41569c2d626552269797e0545fc9122c (diff)
downloadcpython-71868a0066a90519ccc6aeb75673ae882aaa03f0.zip
cpython-71868a0066a90519ccc6aeb75673ae882aaa03f0.tar.gz
cpython-71868a0066a90519ccc6aeb75673ae882aaa03f0.tar.bz2
gh-90005: Rename MODULE_EGG variable to MODULE_EGG_STATE (GH-94301)
It makes it easier to look for module states in sysconfig without special casing suffixes "_CFLAGS", "_DEPS", "_LDFLAGS", "_OBJS", and "CTYPES_MALLOC_CLOSURE".
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index af28007..210d0f4 100644
--- a/setup.py
+++ b/setup.py
@@ -318,7 +318,7 @@ class PyBuildExt(build_ext):
if update_flags:
self.update_extension_flags(ext)
- state = sysconfig.get_config_var(f"MODULE_{ext.name.upper()}")
+ state = sysconfig.get_config_var(f"MODULE_{ext.name.upper()}_STATE")
if state == "yes":
self.extensions.append(ext)
elif state == "disabled":
@@ -329,7 +329,7 @@ class PyBuildExt(build_ext):
# not available on current platform
pass
else:
- # not migrated to MODULE_{name} yet.
+ # not migrated to MODULE_{name}_STATE yet.
self.announce(
f'WARNING: Makefile is missing module variable for "{ext.name}"',
level=2