diff options
author | Eric Snow <ericsnowcurrently@gmail.com> | 2018-01-30 01:23:44 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-01-30 01:23:44 (GMT) |
commit | 7f8bfc9b9a8381ddb768421b5dd5cbd970266190 (patch) | |
tree | 51b8fe00614bdc56c0c32ab2c61d921b225022a8 /setup.py | |
parent | 332cd5ee4ff42c9904c56e68a1028f383f7fc9a8 (diff) | |
download | cpython-7f8bfc9b9a8381ddb768421b5dd5cbd970266190.zip cpython-7f8bfc9b9a8381ddb768421b5dd5cbd970266190.tar.gz cpython-7f8bfc9b9a8381ddb768421b5dd5cbd970266190.tar.bz2 |
bpo-32604: Expose the subinterpreters C-API in a "private" stdlib module. (gh-1748)
The module is primarily intended for internal use in the test suite. Building the module under Windows will come in a follow-up PR.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 4 insertions, 0 deletions
@@ -755,6 +755,10 @@ class PyBuildExt(build_ext): ['_xxtestfuzz/_xxtestfuzz.c', '_xxtestfuzz/fuzzer.c']) ) + # Python interface to subinterpreter C-API. + exts.append(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c'], + define_macros=[('Py_BUILD_CORE', '')])) + # # Here ends the simple stuff. From here on, modules need certain # libraries, are platform-specific, or present other surprises. |