summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-21 09:45:31 (GMT)
committerGitHub <noreply@github.com>2021-11-21 09:45:31 (GMT)
commitf201d261cf53365b5769a434ca2bb21a892bd23f (patch)
treecc769eec3c5fefa09019c435b7e99007674b6b7a /setup.py
parent4f006a789a35f5d1a7ef142bd1304ce167392457 (diff)
downloadcpython-f201d261cf53365b5769a434ca2bb21a892bd23f.zip
cpython-f201d261cf53365b5769a434ca2bb21a892bd23f.tar.gz
cpython-f201d261cf53365b5769a434ca2bb21a892bd23f.tar.bz2
bpo-45847: Port grp, spwd, termios, resource, syslog to PY_STDLIB_MOD (GH-29668)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 7 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index d01cc4f..9ff5969 100644
--- a/setup.py
+++ b/setup.py
@@ -1046,16 +1046,8 @@ class PyBuildExt(build_ext):
self.add(Extension('fcntl', ['fcntlmodule.c'],
libraries=libs))
# grp(3)
- if not VXWORKS:
- self.add(Extension('grp', ['grpmodule.c']))
- # spwd, shadow passwords
- if (self.config_h_vars.get('HAVE_GETSPNAM', False) or
- self.config_h_vars.get('HAVE_GETSPENT', False)):
- self.add(Extension('spwd', ['spwdmodule.c']))
- # AIX has shadow passwords, but access is not via getspent(), etc.
- # module support is not expected so it not 'missing'
- elif not AIX:
- self.missing.append('spwd')
+ self.addext(Extension('grp', ['grpmodule.c']))
+ self.addext(Extension('spwd', ['spwdmodule.c']))
# select(2); not on ancient System V
self.add(Extension('select', ['selectmodule.c']))
@@ -1065,7 +1057,7 @@ class PyBuildExt(build_ext):
# Lance Ellinghaus's syslog module
# syslog daemon interface
- self.add(Extension('syslog', ['syslogmodule.c']))
+ self.addext(Extension('syslog', ['syslogmodule.c']))
# Python interface to subinterpreter C-API.
self.add(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c']))
@@ -1375,15 +1367,10 @@ class PyBuildExt(build_ext):
def detect_platform_specific_exts(self):
# Unix-only modules
- if not MS_WINDOWS:
- if not VXWORKS:
- # Steen Lumholt's termios module
- self.add(Extension('termios', ['termios.c']))
- # Jeremy Hylton's rlimit interface
- self.add(Extension('resource', ['resource.c']))
- else:
- self.missing.extend(['resource', 'termios'])
-
+ # Steen Lumholt's termios module
+ self.addext(Extension('termios', ['termios.c']))
+ # Jeremy Hylton's rlimit interface
+ self.addext(Extension('resource', ['resource.c']))
# linux/soundcard.h or sys/soundcard.h
self.addext(Extension('ossaudiodev', ['ossaudiodev.c']))