summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2002-11-08 13:11:50 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2002-11-08 13:11:50 (GMT)
commit15628fe7bc9c1a2cc149ec44b1ebddd22017ea5d (patch)
tree5c6cd0be2767502cab7502c2b427dc04a3b27db0 /setup.py
parentd5c124af25c9d74cf5af949e965424868e78bd39 (diff)
downloadcpython-15628fe7bc9c1a2cc149ec44b1ebddd22017ea5d.zip
cpython-15628fe7bc9c1a2cc149ec44b1ebddd22017ea5d.tar.gz
cpython-15628fe7bc9c1a2cc149ec44b1ebddd22017ea5d.tar.bz2
Simply delete the fpectl module, instead of leaving it commented out;
if people want to compile it, they should edit Modules/Setup, not setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 0 insertions, 22 deletions
diff --git a/setup.py b/setup.py
index e0c6686..5b11ad9 100644
--- a/setup.py
+++ b/setup.py
@@ -650,28 +650,6 @@ class PyBuildExt(build_ext):
libraries = ['panel'] + curses_libs) )
-
- # Lee Busby's SIGFPE modules.
- # The library to link fpectl with is platform specific.
- # Choose *one* of the options below for fpectl:
-
- # Disabled; it's dangerous or useless except in the hands of experts.
-## if platform == 'irix5':
-## # For SGI IRIX (tested on 5.3):
-## exts.append( Extension('fpectl', ['fpectlmodule.c'],
-## libraries=['fpe']) )
-## elif 0: # XXX how to detect SunPro?
-## # For Solaris with SunPro compiler (tested on Solaris 2.5
-## # with SunPro C 4.2): (Without the compiler you don't have
-## # -lsunmath.)
-## #fpectl fpectlmodule.c -R/opt/SUNWspro/lib -lsunmath -lm
-## pass
-## else:
-## # For other systems: see instructions in fpectlmodule.c.
-## #fpectl fpectlmodule.c ...
-## exts.append( Extension('fpectl', ['fpectlmodule.c']) )
-
-
# Andrew Kuchling's zlib module. Note that some versions of zlib
# 1.1.3 have security problems. See CERT Advisory CA-2002-07:
# http://www.cert.org/advisories/CA-2002-07.html