diff options
author | Jack Jansen <jack.jansen@cwi.nl> | 2002-06-27 22:06:49 (GMT) |
---|---|---|
committer | Jack Jansen <jack.jansen@cwi.nl> | 2002-06-27 22:06:49 (GMT) |
commit | 73aa1fff85c7c6ff940ace1a5de8a895e24e0132 (patch) | |
tree | be63cf841bdad964709e71f3ae0188346f891a81 /setup.py | |
parent | 3d9addd55ab303a1acdb03964ae077c0817988bd (diff) | |
download | cpython-73aa1fff85c7c6ff940ace1a5de8a895e24e0132.zip cpython-73aa1fff85c7c6ff940ace1a5de8a895e24e0132.tar.gz cpython-73aa1fff85c7c6ff940ace1a5de8a895e24e0132.tar.bz2 |
More fixes for building MacPython extension modules. It now actually succeeds
in building various modules.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 34 |
1 files changed, 18 insertions, 16 deletions
@@ -309,10 +309,11 @@ class PyBuildExt(build_ext): # fcntl(2) and ioctl(2) exts.append( Extension('fcntl', ['fcntlmodule.c']) ) - # pwd(3) - exts.append( Extension('pwd', ['pwdmodule.c']) ) - # grp(3) - exts.append( Extension('grp', ['grpmodule.c']) ) + if platform not in ['mac']: + # pwd(3) + exts.append( Extension('pwd', ['pwdmodule.c']) ) + # grp(3) + exts.append( Extension('grp', ['grpmodule.c']) ) # posix (UNIX) errno values exts.append( Extension('errno', ['errnomodule.c']) ) # select(2); not on ancient System V @@ -338,14 +339,15 @@ class PyBuildExt(build_ext): exts.append( Extension('cPickle', ['cPickle.c']) ) # Memory-mapped files (also works on Win32). - if platform not in ['atheos']: + if platform not in ['atheos', 'mac']: exts.append( Extension('mmap', ['mmapmodule.c']) ) # Lance Ellinghaus's modules: # enigma-inspired encryption exts.append( Extension('rotor', ['rotormodule.c']) ) - # syslog daemon interface - exts.append( Extension('syslog', ['syslogmodule.c']) ) + if platform not in ['mac']: + # syslog daemon interface + exts.append( Extension('syslog', ['syslogmodule.c']) ) # George Neville-Neil's timing module: exts.append( Extension('timing', ['timingmodule.c']) ) @@ -381,14 +383,14 @@ class PyBuildExt(build_ext): exts.append( Extension('readline', ['readline.c'], library_dirs=['/usr/lib/termcap'], libraries=readline_libs) ) - - # crypt module. - - if self.compiler.find_library_file(lib_dirs, 'crypt'): - libs = ['crypt'] - else: - libs = [] - exts.append( Extension('crypt', ['cryptmodule.c'], libraries=libs) ) + if platform not in ['mac']: + # crypt module. + + if self.compiler.find_library_file(lib_dirs, 'crypt'): + libs = ['crypt'] + else: + libs = [] + exts.append( Extension('crypt', ['cryptmodule.c'], libraries=libs) ) # socket(2) exts.append( Extension('_socket', ['socketmodule.c'], @@ -535,7 +537,7 @@ class PyBuildExt(build_ext): dblib_dir = None # The standard Unix dbm module: - if platform not in ['cygwin']: + if platform not in ['cygwin', 'mac']: if (self.compiler.find_library_file(lib_dirs, 'ndbm')): exts.append( Extension('dbm', ['dbmmodule.c'], libraries = ['ndbm'] ) ) |