diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2002-11-27 13:43:46 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2002-11-27 13:43:46 (GMT) |
commit | a246d9fefd729294e84a190f2e92cf4e4ff08f20 (patch) | |
tree | 41b2c11eaacd2747ec53fc9d5ad81bf3fc354a2e /setup.py | |
parent | d680a862063535ddd92fdb0c99eb969518033d91 (diff) | |
download | cpython-a246d9fefd729294e84a190f2e92cf4e4ff08f20.zip cpython-a246d9fefd729294e84a190f2e92cf4e4ff08f20.tar.gz cpython-a246d9fefd729294e84a190f2e92cf4e4ff08f20.tar.bz2 |
[Patch #641685] setup.py contained code for finding libraries, instead
of using the CCompiler.find_library_file() provided by the Distutils.
This patch fixes it to use the Distutils method at the cost of some
additional glue.
(The duplication resulted in the SSL module not being automatically
built on Macs; the Distutils knew that shared libraries on OS X have a
.dylib extension, but the setup.py code didn't.)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 32 |
1 files changed, 24 insertions, 8 deletions
@@ -48,14 +48,30 @@ def find_file(filename, std_dirs, paths): return None def find_library_file(compiler, libname, std_dirs, paths): - filename = compiler.library_filename(libname, lib_type='shared') - result = find_file(filename, std_dirs, paths) - if result is not None: return result - - filename = compiler.library_filename(libname, lib_type='static') - result = find_file(filename, std_dirs, paths) - return result - + result = compiler.find_library_file(std_dirs + paths, libname) + if result is None: + return None + + # Check whether the found file is in one of the standard directories + dirname = os.path.dirname(result) + for p in std_dirs: + # Ensure path doesn't end with path separator + if p.endswith(os.sep): + p = p.strip(os.sep) + if p == dirname: + return [ ] + + # Otherwise, it must have been in one of the additional directories, + # so we have to figure out which one. + for p in paths: + # Ensure path doesn't end with path separator + if p.endswith(os.sep): + p = p.strip(os.sep) + if p == dirname: + return [p] + else: + assert False, "Internal error: Path not found in std_dirs or paths" + def module_enabled(extlist, modname): """Returns whether the module 'modname' is present in the list of extensions 'extlist'.""" |