diff options
author | Guido van Rossum <guido@python.org> | 2007-03-08 00:43:48 (GMT) |
---|---|---|
committer | Guido van Rossum <guido@python.org> | 2007-03-08 00:43:48 (GMT) |
commit | a9e2024b8443959cc906958d161afe9f0d08bc25 (patch) | |
tree | e90d1893c99002ba822e9f7e9b4c41ce79923774 /setup.py | |
parent | 4d0f5a4934854207948115b14b4643a6cb600a0d (diff) | |
download | cpython-a9e2024b8443959cc906958d161afe9f0d08bc25.zip cpython-a9e2024b8443959cc906958d161afe9f0d08bc25.tar.gz cpython-a9e2024b8443959cc906958d161afe9f0d08bc25.tar.bz2 |
Check in Daniel Stutzbach's _fileio.c and test_fileio.py
(see SF#1671314) with small tweaks.
The io module now uses this instead of its own implementation
of the FileIO class, if it can import _fileio.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -1037,6 +1037,9 @@ class PyBuildExt(build_ext): # Thomas Heller's _ctypes module self.detect_ctypes(inc_dirs, lib_dirs) + # _fileio -- supposedly cross platform + exts.append(Extension('_fileio', ['_fileio.c'])) + # Platform-specific libraries if platform == 'linux2': # Linux-specific modules |