summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Tishler <jason@tishler.net>2002-08-14 11:13:52 (GMT)
committerJason Tishler <jason@tishler.net>2002-08-14 11:13:52 (GMT)
commitd28216b279743ed680d84fe37da190e9754e6be4 (patch)
treeead21a7f9003521b10cdc0e83d0cab4c6158880e /setup.py
parenteb3f00aeebe619d1e3e74f51bf1d82309cdb2ec5 (diff)
downloadcpython-d28216b279743ed680d84fe37da190e9754e6be4.zip
cpython-d28216b279743ed680d84fe37da190e9754e6be4.tar.gz
cpython-d28216b279743ed680d84fe37da190e9754e6be4.tar.bz2
Patch #588564: _locale library patch
This patch enables setup.py to find gettext routines when they are located in libintl instead of libc. Although I developed this patch for Cygwin, I hope that it can be easily updated to support other platforms (if necessary). I tested this patch under Cygwin and Red Hat Linux 7.1.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bad5130..03a5c20 100644
--- a/setup.py
+++ b/setup.py
@@ -302,7 +302,12 @@ class PyBuildExt(build_ext):
if have_unicode:
exts.append( Extension('unicodedata', ['unicodedata.c']) )
# access to ISO C locale support
- exts.append( Extension('_locale', ['_localemodule.c']) )
+ if platform in ['cygwin']:
+ locale_libs = ['intl']
+ else:
+ locale_libs = []
+ exts.append( Extension('_locale', ['_localemodule.c'],
+ libraries=locale_libs ) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be