summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-10-31 17:11:02 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-10-31 17:11:02 (GMT)
commit076ed00003ef0d94871d9dc070ae42c854a89718 (patch)
treee3915235a00b03decd1bad9e445bedc7ae708a06 /setup.py
parent79263252b1094887c9776b97c1f76956fb0e51b8 (diff)
downloadcpython-076ed00003ef0d94871d9dc070ae42c854a89718.zip
cpython-076ed00003ef0d94871d9dc070ae42c854a89718.tar.gz
cpython-076ed00003ef0d94871d9dc070ae42c854a89718.tar.bz2
add --enable-loadable-sqlite-extensions #10268
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6cb8a28..d7d482e 100644
--- a/setup.py
+++ b/setup.py
@@ -997,8 +997,10 @@ class PyBuildExt(build_ext):
else:
sqlite_defines.append(('MODULE_NAME', '\\"sqlite3\\"'))
- # Comment this out if you want the sqlite3 module to be able to load extensions.
- sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1"))
+ # Enable support for loadable extensions in the sqlite3 module
+ # if --enable-loadable-sqlite-extensions configure option is used.
+ if '--enable-loadable-sqlite-extensions' not in sysconfig.get_config_var("CONFIG_ARGS"):
+ sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1"))
if sys.platform == 'darwin':
# In every directory on the search path search for a dynamic