summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandre Vassalotti <alexandre@peadrop.com>2008-05-09 21:49:43 (GMT)
committerAlexandre Vassalotti <alexandre@peadrop.com>2008-05-09 21:49:43 (GMT)
commit1aed624f7c6051bc670a846825bd40108d3f8dd5 (patch)
treebfb494b5e311d0af801388ba4df04b0e716187c1 /setup.py
parent81673b7b63973bfe386ce6966a69d40cf9c277bc (diff)
downloadcpython-1aed624f7c6051bc670a846825bd40108d3f8dd5.zip
cpython-1aed624f7c6051bc670a846825bd40108d3f8dd5.tar.gz
cpython-1aed624f7c6051bc670a846825bd40108d3f8dd5.tar.bz2
Backport fast alternate io.BytesIO implementation.
Merged r62778, r62779, r62802, r62806, r62807, r62808, r62809, r62844, r62846, r62952, r62956.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d7fac2f..34035ed 100644
--- a/setup.py
+++ b/setup.py
@@ -436,6 +436,8 @@ class PyBuildExt(build_ext):
exts.append( Extension('operator', ['operator.c']) )
# Python 3.0 _fileio module
exts.append( Extension("_fileio", ["_fileio.c"]) )
+ # Python 3.0 _bytesio module
+ exts.append( Extension("_bytesio", ["_bytesio.c"]) )
# _functools
exts.append( Extension("_functools", ["_functoolsmodule.c"]) )
# _json speedups