diff options
author | Éric Araujo <merwok@netwok.org> | 2011-10-19 04:01:57 (GMT) |
---|---|---|
committer | Éric Araujo <merwok@netwok.org> | 2011-10-19 04:01:57 (GMT) |
commit | 5e2d5df477eb244be657a942bdc863bce264d446 (patch) | |
tree | be9c6fe590719b579a94ca0b8dbcc2a20fbbd4f1 /setup.py | |
parent | 1e73a2467f312f7b5ebef515cca6d3a16cf36f97 (diff) | |
download | cpython-5e2d5df477eb244be657a942bdc863bce264d446.zip cpython-5e2d5df477eb244be657a942bdc863bce264d446.tar.gz cpython-5e2d5df477eb244be657a942bdc863bce264d446.tar.bz2 |
Improve Victor’s commit with cool new 2.5 idiom
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -1380,8 +1380,7 @@ class PyBuildExt(build_ext): # End multiprocessing # Platform-specific libraries - if any(platform.startswith(prefix) - for prefix in ("linux", "freebsd", "gnukfreebsd")): + if platform.startswith(('linux', 'freebsd', 'gnukfreebsd')): exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) ) else: missing.append('ossaudiodev') |