diff options
author | Neal Norwitz <nnorwitz@gmail.com> | 2008-03-24 06:22:57 (GMT) |
---|---|---|
committer | Neal Norwitz <nnorwitz@gmail.com> | 2008-03-24 06:22:57 (GMT) |
commit | 6cf49cf10689bf2ff23fff05928daa23ecdf6fc2 (patch) | |
tree | f98ace06aafb9ce7005beb8b3dec94bfec382739 /setup.py | |
parent | e7789b186d640ee00e5709fcfbeca43780d379e4 (diff) | |
download | cpython-6cf49cf10689bf2ff23fff05928daa23ecdf6fc2.zip cpython-6cf49cf10689bf2ff23fff05928daa23ecdf6fc2.tar.gz cpython-6cf49cf10689bf2ff23fff05928daa23ecdf6fc2.tar.bz2 |
Remove the dl module per PEP 3108.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 0 insertions, 11 deletions
@@ -1105,17 +1105,6 @@ class PyBuildExt(build_ext): exts.append(Extension('_codecs_%s' % loc, ['cjkcodecs/_codecs_%s.c' % loc])) - # Dynamic loading module - if sys.maxsize == 0x7fffffff: - # This requires sizeof(int) == sizeof(long) == sizeof(char*) - dl_inc = find_file('dlfcn.h', [], inc_dirs) - if (dl_inc is not None) and (platform not in ['atheos']): - exts.append( Extension('dl', ['dlmodule.c']) ) - else: - missing.append('dl') - else: - missing.append('dl') - # Thomas Heller's _ctypes module self.detect_ctypes(inc_dirs, lib_dirs) |